MouseBits

MouseBits => Technical Assistance => Topic started by: dolbyman on February 07, 2020, 08:51:27 PM

Title: HTTPS cert expired
Post by: dolbyman on February 07, 2020, 08:51:27 PM
Just FYI the https cert just expired

The error message might freak some people out  ;)
Title: Re: HTTPS cert expired
Post by: wcool on February 07, 2020, 10:38:55 PM
This was indeed an issue with an expired LetsEncrypt certificate. I have put up a small writing on the index/homepage to clarify.

If you have any concerns, feel free to post about it in this topic.
Title: Re: HTTPS cert expired
Post by: pixelated on February 08, 2020, 12:50:33 AM
Quote
Please be *censored*ured that there was nothing serious going on.
It's a little disconcerting to see that in the official site News section.

Is the purpose of the censorWholeWord setting in SMF to censor only whole words and not modify substrings?  I see that setting used in the censorText() function in Load.php:
Code: [Select]
$censor_vulgar[$i] = (empty($modSettings['censorWholeWord']) ? '/' . $censor_vulgar[$i] . '/' : '/(?<=^|\W)' . $censor_vulgar[$i] . '(?=$|\W)/') . (empty($modSettings['censorIgnoreCase']) ? '' : 'i') . ((empty($modSettings['global_character_set']) ? $txt['lang_character_set'] : $modSettings['global_character_set']) === 'UTF-8' ? 'u' : '');
Title: Re: HTTPS cert expired
Post by: wcool on February 08, 2020, 01:50:41 AM
That is indeed the purpose. I will test out other, better, forum solutions soon. Will put up a notice when we're going to migrate to a better solution, but without sacrificing usability. I doubt it could be worse than the usability of this forum software if I'm honest...